MAP HANG [just like a lagging server]

MAP HANG [just like a lagging server]

Hammer Mapping — Page [1]
mumair2004
2008 Jan 21 • 4
i have made quite a huge map but it gets stucked in every patch i played it on patch 28 n 32 both run da map n load da textures but it da map hangs again n again like being in some f***** lagging server however i have also tried playin it wid bots
 
 
2008 Jan 23 at 11:09 PST — Ed. 2008 Jan 23 at 11:10 PST
Down Rodeo
Cap'n Moth of the Firehouse

Find the Hole II Participation Medal
2007 Oct 19 • 5486
57,583 ₧
When you say it hangs, I take it that it compiles properly? If so, does it take a long time to compile? Check the log file created, see if it has any warnings etc.
 
 
2008 Jan 23 at 18:24 PST
mumair2004
2008 Jan 21 • 4
it didnt took much time just abt a minute or less then that, no .err file created but a lot of files created during compilation
 
 
2008 Jan 25 at 07:29 PST
SuperJer
Websiteman

2005 Mar 20 • 6232
Lot's of files is normal. Look for an error or warning in your .log file.
 
 
2008 Jan 25 at 13:11 PST
mumair2004
2008 Jan 21 • 4
IT IS LEAK :(

Warning: === LEAK in hull 0 ===
Entity info_player_start @ ,768, -3520, -128>

HOWEVER I HAVE MADE THE ENTITIES FLOATING IN AIR NOT TOUCHING ANY THING[floor, walls or ceiling].
wat 2 do
 
 
2008 Jan 28 at 02:56 PST — Ed. 2008 Jan 28 at 02:57 PST
Down Rodeo
Cap'n Moth of the Firehouse

Find the Hole II Participation Medal
2007 Oct 19 • 5486
57,583 ₧
You have to make sure that all your entities are entirely 'boxed in', that is that there are no leaks. The -3000 number would suggest to me that there is a player start like too far out; it is perhaps not contained by brushes. Have a look for it.

Aside from that you can have a look at the pointfile, this will tell you exactly where the leak is. Plug it!
 
 
2008 Jan 28 at 05:09 PST
SuperJer
Websiteman

2005 Mar 20 • 6232
Click Map->Load Pointfile to view the pointfile in Hammer. Sometimes it helps. Sometimes.
 
 
2008 Jan 28 at 11:25 PST
mumair2004
2008 Jan 21 • 4
loading a pointfile have emerged some mashwork of red lines[Un-Understandable to me] occupying almost more than half of the map however i have resized all the walls to maximum grid and re checked them weither they r just touching or intercepting with each other[some were intercepting the error was removed by resizing] and as i said previously all the players are in space inside the world but there is still leak error:

Warning: === LEAK in hull 0 ===
Entity info_player_start @ ( 768,-3520, 48)

log and err files are also created, i didnt noticed it quite well in first attempt.
 
 
2008 Jan 31 at 02:10 PST — Ed. 2008 Jan 31 at 02:13 PST
SuperJer
Websiteman

2005 Mar 20 • 6232
The red lines from the pointfile can be a mess, but at some point they connect through your leak from the inside to the outside of the map.

Sometimes it can help find the leak.
 
 
2008 Jan 31 at 10:30 PST — Ed. 2008 Jan 31 at 10:30 PST
Page [1]