My Crappy Map Won't Work.

My Crappy Map Won't Work.

Hammer Mapping — Page [1]
winzero
2006 Aug 1 • 3
17 ₧
I'm not sure what it is, I'm not that *Great* at english, Oh and the name of the map might sound weird.. Well this is how the map, " CT/T spawns in the air (like 1hp), either CT/T's can kill eachother =) (There is loads of boxes in the middle *Like boxwars*)or find the *Secret* room wich teleports the character to a tower.

Where you surf down and at the end of it you're supposed to jump in a tunnel * Like surf_water-run *, then you get teleported to a room where you can either choose to go back to the CT/T spawn or to a place with some guns.


Anyways, who cares about what the map is about, Here's what it says:

Here's some pics. Not sure if they are needed, if they are they're here.

Top:


Front:



The side looks just like the top anyway's so who cares about that.

*******This map worked BEFORE i added a few things, like teleport places, a ladder , a sky.


Tell me if you need any file to make it work.

****I'm new to this, this is my first map****

Oh, by the way! is there any good WADconverter? (not for sprays) I'm going to add some credits and that, or is there any other way to do this? The spray wadconverters makes the picture too small to even see a word lol.


hlcsg v2.5.3 rel Custom Build 1.7 (Dec 9 2002)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (merlinis@bigpond.net.au)
----- BEGIN hlcsg -----
Command line: hlcsg surf_25hp
Entering surf_25hp.map

Current hlcsg Settings
Name | Setting | Default
---------------------|-----------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
null texture stripping[ on ] [ on ]
clipnode economy mode [ on ] [ on ]
onlyents [ off ] [ off ]
wadtextures [ on ] [ on ]
skyclip [ on ] [ on ]
hullfile [ None ] [ None ]
min surface area [ 0.500 ] [ 0.500 ]
brush union threshold [ 0.000 ] [ 0.000 ]

Using mapfile wad configuration
Wadinclude list :
[zhlt.wad]

1 brushes (totalling 6 sides) discarded from clipping hulls
CreateBrush:
10%...20%...30%...40%...50%...60%...70%...80%...90%...Error: Entity 226
, Side 0: plane with no normal

Error: plane with no normal
Description: The map has a problem which must be fixed
Howto Fix: Check the file ZHLTProblems.html for a detailed explanation
roblem

Error: Entity 227, Brush 0, Side 0: plane with no normal
(0.27 seconds)

----- END hlcsg -----

*SNIP*


Thanks anyway's!
 
 
2006 Aug 1 at 02:34 PDT
SuperJer
Websiteman

2005 Mar 20 • 6194
You have a bad brush in your map.

It has a side with "no normal." A normal is like an arrow pointing directly away from a surface. All triangles have a normal and games need normals to work. But imagine if you took a corner of the triangle and merged it into another corner. Then it wouldn't be much of a triangle any more. It would just be a line. And lines don't have a normal.

This is what happened in your map.

The error says the problem is in Entity 226 so open your map in Hammer and use Ctrl+Shift+G and find that entity.

Either delete the whole thing or just the offending brush if you can find it.
 
 
2006 Aug 1 at 09:29 PDT
winzero
2006 Aug 1 • 3
17 ₧
Thanks for the help, it worked! But, it said "226" didn't exist but 227 did and i got an error on that one too, so i removed it *It was the ladder*. Now i can play the map and everything, BUT! I still get an error. And it won't teleport me when i walk into the room the teleporter is in as the picture, i have made everything as it should be. "I followed a tutorial". And here's another error, Look what happens:



Oh, and it would be great if you could help me out a little with the coordinates, All surf maps has teleporters, and as you see above mine won't work, it might be something about the coordinates. Mine never seem to work. This is how i do when im testing it (I'm not sure if this is the right way). Here: I create a something with the block tool, i go to "Tools" "Transform" *CTRL + M* i select "Move" then i type in the coordinates. I'm not really sure where to look for the coordinates since there are two places for that, I need some help with finding the right one's.

Wich one is the ones? I'm kinda stupid =S, It should be @-3456, 1920 that one, but when i try it, it goes to a diffrent place.

Or maybe i just missed something in the tutorial.





And here's the text.


----- BEGIN hlcsg -----
*SNIP*
----- END hlcsg -----


----- BEGIN hlbsp -----
*SNIP*
----- END hlbsp -----


----- BEGIN hlvis -----
*SNIP*

Warning: Leaf portals saw into leaf
Problem at portal between leaves 95 and 88:
(-1832.028 -2339.895 64.000)
(-1803.440 -2239.888 167.194)
(-1970.910 -177.802 701.167)
(-2273.574 -64.000 112.787)
(-2296.744 -64.000 64.000)

----- END hlvis -----


----- BEGIN hlrad -----
*SNIP*

4341 faces
Create Patches : 55071 base patches
0 opaque faces
1087548 square feet [156606976.00 square inches]
44 direct lights

BuildFacelights:
(109.67 seconds)
visibility matrix : 180.8 megs
BuildVisLeafs:
(816.39 seconds)
MakeScales:
Error: Memory allocation failure
Description: The program failled to allocate a block of memory.
Howto Fix: Likely causes are (in order of likeliness) : the partition holding the swapfile is full; swapfile size is smaller than required; memory fragmentation; heap corruption

----- END hlrad -----


***Well i guess this is it, I don't know what it is since my english ain't that good, i just know what a normal leaf is and i don't think it's that. lol***

Warning: Leaf portals saw into leaf
Problem at portal between leaves 95 and 88:
(-1832.028 -2339.895 64.000)
(-1803.440 -2239.888 167.194)
(-1970.910 -177.802 701.167)
(-2273.574 -64.000 112.787)
(-2296.744 -64.000 64.000)
 
 
2006 Aug 1 at 22:18 PDT
SuperJer
Websiteman

2005 Mar 20 • 6194
Don't use "Tools" "Transform". It has nothing to do with teleporters.

To make a teleporter, you need a trigger_teleport (brush-based entity) and a info_teleport_destination (point entity).

Give the info_teleport_destination a name and set the target of the trigger_teleport to that name.

That's basically it. The player will teleport to the info_teleport_destination when they step into the trigger_teleport.

------------------------------------------------------------------

There are two things wrong in your screenshot. 1) No shadows (because HLRAD failed, see below). 2) Far away stuff is disappearing. This one is easy. Go to Map->Map Properties... and set the Max Viewable Distance to a higher number. I like to use 16384.

------------------------------------------------------------------

Error: Memory allocation failure

Your computer doesn't have much memory or your HLRAD is just using way too much. The problem is your map is HUGE. You need to scale UP the textures on some of your huge surfaces. This will make the lighting lower resolution and use less memory. Or you can set chop to a higher value, which will cause your lighting to be lower res too:

hlrad -chop 128 surf_25hp
-------------------------------------------------------------------

Warning: Leaf portals saw into leaf

Don't worry about this. With more complex maps, sometimes HLVIS breaks up the map in a way that doesn't quiiiiite work. The result is that from somewhere in the map, some polygons will disappear. You'll probably never find it anyways. They're usually tiny.
 
 
2006 Aug 2 at 10:06 PDT
winzero
2006 Aug 1 • 3
17 ₧
I can now see the map, teleporters works, NO lag, everything works but! The teleporters, teleports me to a diffrent place, i did set target and everything. But when i walk into a teleporter i just end up somewhere in the map.


Thank's for all you're help, you own!


Oh, by the way would you happen to know how to spawn weapons? Most surf maps got a weapon room. And it's hard to have a weapon room with no weapons :P.
 
 
2006 Aug 4 at 00:49 PDT
SuperJer
Websiteman

2005 Mar 20 • 6194
If the name on the trigger_teleport's TARGET is any different from the info_teleport_destination's NAME, then you will probably get teleported to the center of the map.

If you're sure it's all correct... then... uh... I dunno. Your game is broke?
 
 
2006 Aug 4 at 01:01 PDT
EVIL
2006 Mar 1 • 74
22 ₧
no if no name or incorrect name it teleports nowhere i believe its just a bruch that doesnt do anything :P

i made a surfmap my self and they r really hard to compile :/
 
 
2006 Aug 12 at 09:12 PDT
Page [1]