Solid Entity error!

Solid Entity error!

Hammer Mapping — Page [1]
Prank
2010 Jan 25 • 9
when i click Alt P to check errors it says: "Solid Entity[Button_target] is empty".
but when i start the map to test it it says that i got a Leak.
it totally fucks my lights up.
i havent added any new rooms or tunels or anything, all i did was to take a ladder texture and paste it on the wall and then delete it :S
i try to click "Fix error" but it doesnt work.
and when i click "Go to error" it takes me to a blank space outside the map.

Help
 
 
2010 Jan 25 at 12:55 PST — Ed. 2010 Jan 25 at 14:10 PST
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
These errors are probably(?) not related to each other:

A leak in the map is usually caused by either a point-entity which has been placed outside the map (in the black void) or a hole in your map which exposes the inside of your map to the black void outside. You can find a leak easier by using a pointfile, "Map" ---> "Load pointfile" and load the .lin-file with the same name as your map, a line will be drawn in the 3d/2d-views, follow the line and see where it goes outside the map, that's probably where the leak is.

About the "solid entity empty"-error, bring up the error-report, select the error and press the "Go to error"-button then immediately press the Delete-key on your keyboard and that should delete the empty entity. (I think)

QUACK! QUACK!
 
 
2010 Jan 25 at 14:20 PST — Ed. 2010 Jan 25 at 14:22 PST
Prank
2010 Jan 25 • 9
i tried the "Go to error" and delete immediatly thing, it didnt work. the error thing is still there, i also tried to put a Huge box around my whole map so its like inside a huge room. the Leak dissapeared. i cant seem to find any holes in my map, and i cant find the entity thats causing this trouble either :/
 
 
2010 Jan 25 at 14:27 PST
Prank
2010 Jan 25 • 9
i did as u said with the pointline thing aswell, nothing happened :S no line appeared. does that mean i dont have a "hole" in my map and the leak is caused by something else?
 
 
2010 Jan 25 at 14:30 PST
Prank
2010 Jan 25 • 9
i found the leak x) but i still have the Entity error thingy
 
 
2010 Jan 25 at 14:52 PST
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
Start up the Entity report (Map-->Entity report...), and find the button_target-enity in the list and delete it from there.

(If you have multiple button_targets you can select one of them and press the "Go to"-button, if nothing gets selected in the 2d/3d-views then that entity can be deleted since it's "empty". Repeat until you find the empty one.)
QUACK! QUACK!
 
 
2010 Jan 25 at 14:58 PST — Ed. 2010 Jan 25 at 14:58 PST
Page [1]