Solid Entity (func_ladder) is empty.

Solid Entity (func_ladder) is empty.

Hammer Mapping — Page [1]
LivingDog

2009 Jan 29 • 20
I tried to create a ladder with the instructions in the superjer article but this time up against a cylinder. To match the side with the ladder I used wedges with no grid. It looked beautiful.

However, Alt-P revealed two identical errors "Solid ...". After struggling with the build I decided to start from scratch keeping my cylinder. That didn't work. So I went back one more step and deleted the cylinder ... the two errors still appeared with the cylinder deleted. (Ctrl-Z brought the cylinder back.)

I've built a working ladder up against a wall but for some reason my understanding hit a wall and this cylinder is really frustrating me.

I used two wedges for the CLIMBY and VISUAL bits. These matched the angle of the face on the 8 sided cylinder. Now I think I am trying to do something that wasn't meant to be done?

And finally, I have tried to build only _1_ ladder - so after deleting all of the parts how can I still be getting this error??

Oh... one last thing, when I try to compile the exported .MAP file the error log refers to "Entity 17 ... " - are the entities numbered so I can locate which entity to which it is referring?

Thanks in advance.


-LD
________________
my faith
 
 
2009 Feb 6 at 21:26 PST — Ed. 2009 Feb 6 at 21:32 PST
headtanner
2009 Jan 25 • 32
i don't think it has anything to do with the cyclinder cause some of my maps have ladders in mid air
Learn From Yesterday, Live for Today, Hope for Tomorrow
 
 
2009 Feb 6 at 21:48 PST — Ed. 2009 Feb 6 at 21:48 PST
headtanner
2009 Jan 25 • 32
heres a link to a tut video i made on ladder in valve hammer edidtor
http://www.youtube.com/watch?v=MAT3e1nReC0 if its not processed yet then wait for 10 min and try again
Learn From Yesterday, Live for Today, Hope for Tomorrow
 
 
2009 Feb 6 at 22:32 PST
Mate de Vita
Kelli

2008 Oct 4 • 2453
159 ₧
This error sometimes occurs when you tie a brush to an entity and then delete the brush. Why, I have no idea.

Anyway go under Map->Entity report and filter brush entities only.
Now select each one of the in your case func_ladders and press 'go to'. If it selects something then select the next func_ladder. If it doesn't select anything, press 'delete'. Repeat this until you've deleted all the 'empty entities'. Then press alt+p again to check just in case you missed one.
...and that's the bottom line because Mate de Vita said so.
 
 
2009 Feb 7 at 01:45 PST
LivingDog

2009 Jan 29 • 20
Mate de Vita said:
This error sometimes occurs when you tie a brush to an entity and then delete the brush. Why, I have no idea.

Anyway go under Map->Entity report and filter brush entities only.
Now select each one of the in your case func_ladders and press 'go to'. If it selects something then select the next func_ladder. If it doesn't select anything, press 'delete'. Repeat this until you've deleted all the 'empty entities'. Then press alt+p again to check just in case you missed one.



AHHAHAHAhhhahahahaha ... worked exactly as u said dude! u da' man!
THANKS THANKS THANKS no more empty ladders :):)

BTW, it did select "nothing" as it was doing before when I tried to fix it... oh, this is weird. When I hit "fix" it .. ohhhh it was trying to fix something that wasn't there, but MAP->ENTITY REPORT lets you delete it - very different action ... um ... deleting something that isn't there ... w e i r d :)

thx again!


-LD
________________
my faith
 
 
2009 Feb 7 at 18:36 PST — Ed. 2009 Feb 7 at 18:39 PST
LivingDog

2009 Jan 29 • 20
headtanner said:
heres a link to a tut video i made on ladder in valve hammer edidtor
http://www.youtube.com/watch?v=MAT3e1nReC0 if its not processed yet then wait for 10 min and try again


Thanks! I bookmarked it in case I ever get confused again! :)

-LD
________________
my faith
 
 
2009 Feb 7 at 18:37 PST
LivingDog

2009 Jan 29 • 20
Alt-p = No errors were found.

--

C:\zhlt\<file>.bat

. . .

Error: Entity 17 has no visible brushes

Error: No visible brushes
Description: All brushes are CLIP or ORIGIN (at least one must be normal/visible)

--

I think the problem is that what I am trying is not possible - or needs some clever work around that my inexperienced self does not know about VHE enough to figure out.

I am trying to use one face of an octagon shaped cylinder as the CLIP brush. I thought that changing the entire cylinder to a CLIP brush might be the fix, but nah uh... I took a snap to show you my idea (only the thumb image is bad):

[URL=http://img19.imageshack.us/my.php?image=ladderproblemwy3.jpg]
[IMG]http://img19.imageshack.us/img19/9907/ladderproblemwy3.jpg[/IMG]
[/URL]

I rotated the AAATRIGGER brush so it is flush with that face of the octagon, and then rotated the ladder part (func_illusionary) in the same way, but made sure it is in front of the AAATRIGGER and CLIP parts.

-LD
________________
my faith
 
 
2009 Feb 7 at 21:24 PST — Ed. 2009 Feb 8 at 06:04 PST
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
What exactly are you trying to do?
QUACK! QUACK!
 
 
2009 Feb 8 at 03:11 PST
LivingDog

2009 Jan 29 • 20
I am trying to mount a ladder on one face of an octagon cylinder.

I thought only the face needed to be CLIP - nope.

I thought the cylinder needed to be CLIP - nope.

I thought I needed a separate CLIP brush - nope.

Nothing seems to work. I made a ladder in a box with no problems... yet this seems impossible.

-LD
________________
my faith
 
 
2009 Feb 8 at 05:58 PST
Down Rodeo
Cap'n Moth of the Firehouse

Find the Hole II Participation Medal
2007 Oct 19 • 5486
57,583 ₧
The CLIP brush stops players going through but allows bullets and grenades through. I'd advise texturing the octagon how you want then placing a clip brush just where the ladder is, same shape etc. In fact is the CLIP even needed? I dunno.
 
 
2009 Feb 8 at 06:04 PST
LivingDog

2009 Jan 29 • 20
I did that in my last attempt to fix this! "I thought I needed a separate CLIP brush - nope."

Are the entities numbered? (I need a textbook ) Maybe I can find the problem using this info? I did try MAP->Entity report but it shows the correct list of ... wait a sec... CLIP => ladder but ORIGIN => door! Could the problem be with one of my doors???

"ENTITY 17"???

-LD
________________
my faith
 
 
2009 Feb 8 at 06:48 PST
LivingDog

2009 Jan 29 • 20
IT WAS THE DOOR!!!

I had a mindset that what I was doing was wrong - so naturally I fixated on the focus of that - the ladder!

Octagon Ladder 01

Octagon Ladder 02

So you all can now call me King Creole!

Thanks for all the help guys!

-LD
________________
my faith
 
 
2009 Feb 8 at 07:13 PST — Ed. 2009 Feb 8 at 07:18 PST
Down Rodeo
Cap'n Moth of the Firehouse

Find the Hole II Participation Medal
2007 Oct 19 • 5486
57,583 ₧
 
 
2009 Feb 8 at 07:15 PST
Page [1]