"The system cannot find the file specified."

"The system cannot find the file specified."

Hammer Mapping — Page [1]
beggi90
2010 Sep 11 • 14
Hi I have been working on my map for a while at the last compiling I got the error "The system cannot find the file specified.".

I think this has something to do with hammer I must have f*cked some settings up or something.

I have tried making new map in hammer and I got the same error (empty room with a spawn only with halflife.wad)

Compile log:



** Executing...
** Command: Change Directory
** Parameters: "C:\Program Files\Steam\steamapps\halldorr\counter-strike"


** Executing...
** Command: C:\HAMMER~1\ZHLT34~1\hlbsp.exe
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"

hlbsp v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlbsp -----
Command line: C:\HAMMER~1\ZHLT34~1\hlbsp.exe "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.

----- END hlbsp -----




** Executing...
** Command: C:\HAMMER~1\ZHLT34~1\hlvis.exe
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"

hlvis v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlvis -----
Command line: C:\HAMMER~1\ZHLT34~1\hlvis.exe "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.

----- END hlvis -----




** Executing...
** Command: C:\HAMMER~1\ZHLT34~1\hlrad.exe
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"

hlrad v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlrad -----
Command line: C:\HAMMER~1\ZHLT34~1\hlrad.exe "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.

----- END hlrad -----




** Executing...
** Command: Copy File
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest.bsp" "C:\Program Files\Steam\steamapps\halldorr\counter-strike\cstrike\maps\holtavegurtest.bsp"

The command failed. Windows reported the error:
"The system cannot find the file specified."

** Executing...
** Command: Copy File
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest.pts" "C:\Program Files\Steam\steamapps\halldorr\counter-strike\cstrike\maps\holtavegurtest.pts"

The command failed. Windows reported the error:
"The system cannot find the file specified."




I'm hoping I am doing some idiotic easy fixable mistake although I did not find the fix from google.
 
 
2010 Sep 11 at 08:31 PDT
nectar
2010 Mar 8 • 232
ok, write what u wrote at catpee.bat and send me the name of ur map that u saved it
I love cows and monkeys including cookies :D
 
 
2010 Sep 11 at 08:57 PDT
nectar
2010 Mar 8 • 232
try putting the name of ur file catpee.map
I love cows and monkeys including cookies :D
 
 
2010 Sep 11 at 08:59 PDT
beggi90
2010 Sep 11 • 14
I have tried to change the filename, change the location of the file nothing has changed. My guess is that I must have changed some settings by accident and have no idea how to change it back.

I have compiled this map so many times and errors don't come for no reason.
 
 
2010 Sep 11 at 09:10 PDT
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧
** Command: C:\HAMMER~1\ZHLT34~1\hlrad.exe
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"

Look at the directories. They are not in the same folder. They have to be in the same folder.
 
 
2010 Sep 11 at 09:18 PDT
beggi90
2010 Sep 11 • 14
** Executing...
** Command: C:\DOCUME~1\Beggi\MYDOCU~1\Mapping\hlrad.exe
** Parameters: "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"

Now they are in the same folder but that didn't change anything.
(I had always had it the other way so I'm surprised that that should be a problem)
 
 
2010 Sep 11 at 09:23 PDT
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧
beggi90 said:

** Command: C:\DOCUME~1\Beggi\MYDOCU~1\Mapping\hlrad.exe

Correct me if I'm wrong, but you're working from a temporary directory?
 
 
2010 Sep 11 at 09:28 PDT
beggi90
2010 Sep 11 • 14
No idea why it looks like this but i put them all in the same directory that I created.
 
 
2010 Sep 11 at 09:38 PDT
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.
 
 
2010 Sep 11 at 10:01 PDT
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
Why is hlbsp running first? hlcsg should run first, then hlbsp, hlvis and lastly hlrad.
QUACK! QUACK!
 
 
2010 Sep 11 at 10:03 PDT
beggi90
2010 Sep 11 • 14
This is what the holtavegurtest.log says:

hlbsp v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlbsp -----
Command line: C:\DOCUME~1\Beggi\MYDOCU~1\Mapping\hlbsp.exe "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.

----- END hlbsp -----



hlvis v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlvis -----
Command line: C:\DOCUME~1\Beggi\MYDOCU~1\Mapping\hlvis.exe "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.

----- END hlvis -----



hlrad v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlrad -----
Command line: C:\DOCUME~1\Beggi\MYDOCU~1\Mapping\hlrad.exe "c:\documents and settings\beggi\my documents\mapping\holtavegurtest"
>> There was a problem compiling the map.
>> Check the file c:\documents and settings\beggi\my documents\mapping\holtavegurtest.log for the cause.

----- END hlrad -----
 
 
2010 Sep 11 at 10:03 PDT
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
Are you compiling with a .bat-file or from Hammer?
QUACK! QUACK!
 
 
2010 Sep 11 at 10:04 PDT
beggi90
2010 Sep 11 • 14
Killer-Duck said:
Why is hlbsp running first? hlcsg should run first, then hlbsp, hlvis and lastly hlrad.


how do I change that?
I am compiling from hammer.
 
 
2010 Sep 11 at 10:05 PDT — Ed. 2010 Sep 11 at 10:05 PDT
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
Tools-->Options-->"Build programs" and make sure the four paths for the tools(CSG, vis, rad, bsp) points to the correct .exe-file.

And when you're about to compile the map, make sure that in the compile settings all the four tools are set to "Normal"

QUACK! QUACK!
 
 
2010 Sep 11 at 10:06 PDT — Ed. 2010 Sep 11 at 10:11 PDT
beggi90
2010 Sep 11 • 14
Thanks it worked to go from advanced mode and just put normal to them all.
It started compiling and I will see if it compiled successfully after about an hour.
 
 
2010 Sep 11 at 10:11 PDT
Down Rodeo
Cap'n Moth of the Firehouse

Find the Hole II Participation Medal
2007 Oct 19 • 5486
57,583 ₧
sprinkles said:
beggi90 said:

** Command: C:\DOCUME~1\Beggi\MYDOCU~1\Mapping\hlrad.exe

Correct me if I'm wrong, but you're working from a temporary directory?

That's not a temporary directory, that's the DOS way of writing Windows file paths. Each folder can have a maximum of 8 characters; the tilde means bits have been chopped off then the number identifies it uniquely. The files then have to be in "8.3" format. So restrictive!
 
 
2010 Sep 11 at 10:18 PDT
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧
I thought Windows also used tildes for temporary directories?
 
 
2010 Sep 11 at 10:42 PDT
Down Rodeo
Cap'n Moth of the Firehouse

Find the Hole II Participation Medal
2007 Oct 19 • 5486
57,583 ₧
 
 
2010 Sep 11 at 10:57 PDT
beggi90
2010 Sep 11 • 14
Killer-Duck said:
Tools-->Options-->"Build programs" and make sure the four paths for the tools(CSG, vis, rad, bsp) points to the correct .exe-file.

And when you're about to compile the map, make sure that in the compile settings all the four tools are set to "Normal"



Again thanks you are a lifesaver!
 
 
2010 Sep 11 at 12:12 PDT
Page [1]