Warning - Leak in Hull

Warning - Leak in Hull

Hammer Mapping — Page [1]
MadwiX
2012 Feb 10 • 11
Hi people, I don't know if this forum is dead or not, but I'll post anyways in hope to get an answer. So, I've been struggling with this for some quite time now. I made a map, tested it on my computer (through Files --> Run in VHE) and with HLDS. It worked fine. Then I tried uploading it to my game server but whenever I change to that map the server crashes and needs to be restarted.

So I noticed some errors, which are:

Warning: === LEAK in hull 0 ===

Here's the compile progress:

code

** Executing...
** Command: Change Directory
** Parameters: C:\games\CS1.6v44


** Executing...
** Command: Copy File
** Parameters: "C:\Documents and Settings\Marko\Desktop\Marko\mape\deathrun_8b.map" "C:\games\CS1.6v44\cstrike\maps\deathrun_8b.map"


** Executing...
** Command: C:\DOCUME~1\Marko\Desktop\Marko\zhlt\hlcsg.exe
** Parameters: "C:\games\CS1.6v44\cstrike\maps\deathrun_8b"

hlcsg v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlcsg -----
Command line: C:\DOCUME~1\Marko\Desktop\Marko\zhlt\hlcsg.exe C:\games\CS1.6v44\cstrike\maps\deathrun_8b
Entering C:\games\CS1.6v44\cstrike\maps\deathrun_8b.map

Current hlcsg Settings
Name | Setting | Default
---------------------|-----------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
max lighting memory [ 6291456 ] [ 6291456 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
null texture stripping[ on ] [ on ]
clipnode economy mode [ on ] [ on ]
clip hull type [ legacy ] [ legacy ]
onlyents [ off ] [ off ]
wadtextures [ on ] [ on ]
skyclip [ on ] [ on ]
hullfile [ None ] [ None ]
nullfile [ None ] [ None ]
min surface area [ 0.500 ] [ 0.500 ]
brush union threshold [ 0.000 ] [ 0.000 ]

Using mapfile wad configuration
Wadinclude list :
[zhlt.wad]

0 brushes (totalling 0 sides) discarded from clipping hulls
CreateBrush:
10%...20%...30%...40%...50%...60%...80%...90%... (0.06 seconds)
SetModelCenters:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.00 seconds)
CSGBrush:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (0.20 seconds)

Using Wadfile: \games\cs1.6v44\cstrike\cs_bdog.wad
- Contains 0 used textures, 0.00 percent of map (132 textures in wad)
Using Wadfile: \games\cs1.6v44\cstrike\cs_dust.wad
- Contains 1 used texture, 5.00 percent of map (28 textures in wad)
Using Wadfile: \games\cs1.6v44\cstrike\cstrike.wad
- Contains 0 used textures, 0.00 percent of map (123 textures in wad)
Using Wadfile: \games\cs1.6v44\cstrike\de_aztec.wad
- Warning: Larger than expected texture (348972 bytes): 'SPECIAL_THANKS'
- Warning: Larger than expected texture (348972 bytes): 'THANKS'
- Contains 0 used textures, 0.00 percent of map (24 textures in wad)
Using Wadfile: \games\cs1.6v44\valve\decals.wad
- Contains 0 used textures, 0.00 percent of map (222 textures in wad)
Using Wadfile: \games\cs1.6v44\valve\halflife.wad
- Contains 18 used textures, 90.00 percent of map (3116 textures in wad)
Using Wadfile: \games\cs1.6v44\cstrike\liquids.wad
- Contains 1 used texture, 5.00 percent of map (32 textures in wad)
Including Wadfile: \games\cs1.6v44\cstrike\zhlt.wad
- Contains 0 used textures, 0.00 percent of map (7 textures in wad)

added 1 additional animating textures.
Texture usage is at 0.23 mb (of 4.00 mb MAX)
0.34 seconds elapsed

----- END hlcsg -----




** Executing...
** Command: C:\DOCUME~1\Marko\Desktop\Marko\zhlt\hlbsp.exe
** Parameters: "C:\games\CS1.6v44\cstrike\maps\deathrun_8b"

hlbsp v3.4 Final (Feb 25 2006)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlbsp -----
Command line: C:\DOCUME~1\Marko\Desktop\Marko\zhlt\hlbsp.exe C:\games\CS1.6v44\cstrike\maps\deathrun_8b

Current hlbsp Settings
Name | Setting | Default
-------------------|-----------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
nofill [ off ] [ off ]
noopt [ off ] [ off ]
null tex. stripping [ on ] [ on ]
notjunc [ off ] [ off ]
subdivide size [ 240 ] [ 240 ] (Min 64) (Max 512)
max node size [ 1024 ] [ 1024 ] (Min 64) (Max 8192)


SolidBSP [hull 0] 500...534 (0.06 seconds)
Warning: === LEAK in hull 0 ===
Entity light @ ( 165,-2058, -32)
Error:
A LEAK is a hole in the map, where the inside of it is exposed to the
(unwanted) outside region. The entity listed in the error is just a helpful
indication of where the beginning of the leak pointfile starts, so the
beginning of the line can be quickly found and traced to until reaching the
outside. Unless this entity is accidentally on the outside of the map, it
probably should not be deleted. Some complex rotating objects entities need
their origins outside the map. To deal with these, just enclose the origin
brush with a solid world brush

Leak pointfile generated

SolidBSP [hull 1] 470 (0.09 seconds)
Warning: === LEAK in hull 1 ===
Entity env_explosion @ (1599,-1126,-192)
SolidBSP [hull 2] 454 (0.06 seconds)
Warning: === LEAK in hull 2 ===
Entity env_explosion @ (1599,-1126,-192)
SolidBSP [hull 3] 489 (0.08 seconds)
Warning: === LEAK in hull 3 ===
Entity light @ ( 165,-2058, -32)
0.75 seconds elapsed

----- END hlbsp -----





So I tried loading the .pts file, and I found a leak, so I moved the whole map to the center and patched the leaks. And now it's giving me those red scribblings in a place which doesn't have any blocks, entities or we.

 
 
2012 Feb 10 at 19:12 PST
SRAW
Rocket Man

2007 Nov 6 • 2525
601 ₧
In your screenshot, you can see in the camera the aaatrigger texture is leaking out, and so thats probably your leak

and this forum is sorta dead, but not THAT dead
Free Steam Games
 
 
2012 Feb 10 at 20:30 PST
MadwiX
2012 Feb 10 • 11
Yep, I pulled it in, still finds leak. The thing is, the map works without lagging, but only if my pistol is pointed to the left side, as soon as I turn my pistol right it starts lagging. Also, is there any other way of finding leaks that isn't following that red line because it's really confusing? Also, when I try to compile my map with skybox around it, VHE just freezes and then I have to shut it down via Task Manager. I have 768 MB of RAM.
 
 
2012 Feb 11 at 11:17 PST
SRAW
Rocket Man

2007 Nov 6 • 2525
601 ₧
Well, you said when you point it to the right side it starts lagging, so theres probably a leak there. And a good method to find leaks is too fill up an area of your map in which you believe may have leaks with a giant block, and then compile your map. If it compiles well, you know the leak is in that area.
Free Steam Games
 
 
2012 Feb 11 at 14:50 PST
MadwiX
2012 Feb 10 • 11
I tried that, it compiles fine with no errors, but when I enter the game, it's all messed up, I can only see the void and the sky.
Could I by any chance get your MSN, send you the map for you to see what I'm doing wrong.. ?

Thank you.
 
 
2012 Feb 11 at 14:52 PST
SRAW
Rocket Man

2007 Nov 6 • 2525
601 ₧
Just upload the map to rapidshare, and I don't wanna log in to msn cause then people I don't even know will talk to me, and I have no idea why cause I don't even like them
Free Steam Games
 
 
2012 Feb 11 at 15:59 PST
MadwiX
2012 Feb 10 • 11
Lawl, okay.
I had to make an account for Rapidshare so I uploaded it to filebeam. Hope that's ok, here's the link:

http://fbe.am/1tm
 
 
2012 Feb 11 at 16:40 PST
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧


And, this certainly does not help your lag issue:
Quote:
- Warning: Larger than expected texture (348972 bytes): 'SPECIAL_THANKS'
- Warning: Larger than expected texture (348972 bytes): 'THANKS'
 
 
2012 Feb 11 at 17:03 PST — Ed. 2012 Feb 11 at 17:06 PST
MadwiX
2012 Feb 10 • 11
I don't know what are you pointing on that ss, but everything in that area is patched and sealed, at least in my map on my computer. If not that, then what?

Also, ty for that, didn't even see that two warnings.
 
 
2012 Feb 11 at 17:49 PST
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧
Delete the map and start over.

Do you have "snap to grid" turned off, or do you have the grid size set to 1? NOTHING in your map lines up. It's not a surprise you have leaks everywhere.
 
 
2012 Feb 11 at 18:30 PST
MadwiX
2012 Feb 10 • 11
Snap to grid is on but yeah, it's the big one.

So I should definatly start over?
 
 
2012 Feb 11 at 18:31 PST — Ed. 2012 Feb 11 at 18:37 PST
sprinkles

Chrome Whore
2009 Sep 6 • 2547
10 ₧
The map is small and simple. The time it would take you to fix the leaks would be far greater than the time it would take to rebuild the map. It'd probably take you 20-30 mins to fix the leaks, rebuilding the map would take 2-3 mins.
 
 
2012 Feb 11 at 19:14 PST
MadwiX
2012 Feb 10 • 11
Okay, thanks. I'll put you in map credits in thank you part.
 
 
2012 Feb 12 at 08:59 PST
Page [1]