Why can't Bots use my map ???

Why can't Bots use my map ???

Hammer Mapping — Page [1]
NoLimitADEON
2007 Dec 9 • 8
1 ₧
I've built 2 maps...on one of them i can play with bot's on it...But with the second one...after the bot's start to analize my map...my Counter-Strike shut's down every time....WHY ? AND WHAT CAN I DO TO FIX IT?


PS :Without bot's my map works perfectly
adi
 
 
2008 Apr 5 at 08:30 PDT
dingdong

2008 Feb 23 • 52
See the bots can't just use a map, they have to learn it to know where to go. If you have a really big map or one with wierd teleports or something, the bots have alot to process, which might be the reason it crashes
HAMMER TIME
 
 
2008 Apr 5 at 09:38 PDT
NoLimitADEON
2007 Dec 9 • 8
1 ₧
Well...that's just it...my my map is small (kind of like iceworld)....and teleports?...hell i don't even know how to make one:))...the thing is it's small, it's indoor, dosen't have "teleports", "guns on the ground", not eve windows :))(only a small opening on the roof (wich i filed with sky texture) , but that's it, the players are not close togheter....Wy won't it work? (i made the map really detailed with brushes but I don't thing that's the cause)

PS : the map is 36 players...can this be a problem?...i've tried puting just 2vs2, but now my map dosen't work at all, it compiles, and evrything, but when i load it up, it dosen't want to work at all, not just with bots, but not even real players...DAMN!
adi
 
 
2008 Apr 13 at 02:09 PDT
begginer

2007 Oct 24 • 990
13 ₧
hmm strange .. there are some maps that ive seen that work just fine for players but bots just don't move at all / get stuck in walls in those maps ..

ive found that this can be repaired ( some times ) by going into your maps folder and deleting mapname.nav file and then opening your map in the game ( Not in test mode ) and letting the bots learn it again ..

this works ( sometimes ) because the bots had some problem learning the map , if it was just a one-time error then the bots should learn it correctly the next time , if not then there is something thats not working right

this could be something in your map , the game mod that you use mite have some problem

i saw that in most cases knife-only ( ka_ ) maps have this kind of problem , or if a map has some strange stuff in it , that bots can't really " understand "

but you said that you don't have anything complex in your map ..

what game did you open it in ? did you get any kind of error :
A ) while complying
B ) when trying to test the map

check your .log file ... and maybe post whats in your console when you try to play your map .
Wtf is that ? its a bird ! no its a plane ! amm maybe its a plastic bag . NO ! its SUPERJER ! the greatest super hero ever!
 
 
2008 Apr 13 at 02:22 PDT — Ed. 2008 Apr 13 at 02:26 PDT
NoLimitADEON
2007 Dec 9 • 8
1 ₧
Hmm...yeah...i'll give it a try..thanks allought for the reply man, i'll post again if it worked danke:D
adi
 
 
2008 Apr 13 at 02:54 PDT
NoLimitADEON
2007 Dec 9 • 8
1 ₧
Well sorry to say it did't work...the thing is the map won't let the bots learn the map at all, thus it dosen't have time to create the mapname.nav....so i don't have what to delete:(...whem the bots start to analyze the map, my CS blocks and i have to use the TASK MANAGER to shut it down....


Se la vie! (my french sucks!)
adi
 
 
2008 Apr 13 at 03:17 PDT
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
As begginer said, are there any errors in the compile log?

Also, for which game is this? CS 1.6 or CS:CZ?
QUACK! QUACK!
 
 
2008 Apr 13 at 03:39 PDT
NoLimitADEON
2007 Dec 9 • 8
1 ₧
No there aren't errors, and this is for CS 1.6...


Anyway, it dosen't matter..i've found out what was wrong, u see, i've made a map that looked like the bombsite A in "de_train" map
and the trouble was the trains in the map, for some reason the bots can't learn it,anyway after i deleted the trains, it worked perfectly, with and without bots, now i just got to figure out what part of the train is not right(the brush, or the texture),i'll post my result...

Thank's to all who replied, apreciete it....se'ya !
adi
 
 
2008 Apr 13 at 06:39 PDT
Page [1]