Bots stupid as hell?

Bots stupid as hell?

Hammer Mapping — Page [1]
Ice Mage
2009 Mar 3 • 15
I created quite a small map, and when I start it the bots just run / jump around senselessly and don't really try to find the enemy at all or something. They just run back and forth. Why is this happening?
 
 
2009 May 1 at 06:09 PDT
Mate de Vita
Kelli

2008 Oct 4 • 2453
159 ₧
Open up the console and write bot_nav_analyze then restart and try again.

Oh and at least 1 bot has to be present in the game for this to work.
...and that's the bottom line because Mate de Vita said so.
 
 
2009 May 1 at 06:10 PDT — Ed. 2009 May 1 at 06:11 PDT
Ice Mage
2009 Mar 3 • 15
Mate de Vita said:
Open up the console and write bot_nav_analyze then restart and try again.

Oh and at least 1 bot has to be present in the game for this to work.


Still doesn't work. It just restarts and the bots still act as if they have an IQ of -30.
 
 
2009 May 1 at 06:19 PDT
Mate de Vita
Kelli

2008 Oct 4 • 2453
159 ₧
Do they do OK on the default maps (maps like de_dust, de_inferno etc.) and other custom maps (downloaded maps, e.g. awp_l337sk337 from this site)?
...and that's the bottom line because Mate de Vita said so.
 
 
2009 May 1 at 06:32 PDT
Ice Mage
2009 Mar 3 • 15
Mate de Vita said:
Do they do OK on the default maps (maps like de_dust, de_inferno etc.) and other custom maps (downloaded maps, e.g. awp_l337sk337 from this site)?


Yes they do fine on normal maps. I'll try that map now.
 
 
2009 May 1 at 06:36 PDT
Ice Mage
2009 Mar 3 • 15
They also do fine on that map (awesome map btw :D).
 
 
2009 May 1 at 06:51 PDT
Killer-Duck
Homicidal Anatidae

2008 Mar 5 • 1169
633 ₧
Which version of CS?
QUACK! QUACK!
 
 
2009 May 1 at 08:58 PDT
Ice Mage
2009 Mar 3 • 15
Killer-Duck said:
Which version of CS?


1.6.
 
 
2009 May 1 at 11:05 PDT
Mate de Vita
Kelli

2008 Oct 4 • 2453
159 ₧
So you're using 3rd party bots? Which ones (I think if you write bot_about in the console, you get info about the version)?

Also what's your map like? Does it have a lot of obstacles?
...and that's the bottom line because Mate de Vita said so.
 
 
2009 May 1 at 11:21 PDT — Ed. 2009 May 1 at 11:25 PDT
Ice Mage
2009 Mar 3 • 15
It's the official CS Bot Version 1.50

The map isn't too complicated at all. It's just a single room with a wall inbetween and some boxes. Could it be that the map simply is too small?
 
 
2009 May 1 at 11:30 PDT
titanium00neon

2009 Mar 31 • 51
No. Go to cstrike\maps and if your map is named mapname.bsp, delete mapname.nav file. So the same name but the .nav extension. Open CS 1.6, run map, and add only one bot. That's the automatic way...
And I have no more to say.
 
 
2009 May 1 at 12:45 PDT — Ed. 2009 May 1 at 12:45 PDT
Ice Mage
2009 Mar 3 • 15
Thanks, that did it. Turns out I created another map with the same name before that one, and this one tried to use the old .nav file, which obviously caused problems.

Thanks again.
 
 
2009 May 2 at 01:32 PDT
Page [1]